Integrated Motion
0
Items : 0
Subtotal : 0,00 
View CartCheck Out

[SOLVED] Very long (1~2 second) delay in control of second slave

Home Forums SOMANET Software Communication layer software [SOLVED] Very long (1~2 second) delay in control of second slave

This topic contains 0 replies, has 0 voices, and was last updated by  casey.carlin 3 years, 8 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #1497

    casey.carlin

    I am able to control two nodes running the stock EtherCAT firmware using the demo master/slave programs, but the second node in the chain is always a second or two behind the first one.  At first I thought this was the default behavior of the master app, but when I modified it to use joystick control, I could see slave 0 react immediately but slave 1 was always a couple of seconds behind.  Furthermore, when using the examples, the velocity profile took visibly longer to spin the wheel up. This become more obvious when I requested higher speeds. In short, it’s almost like the slave 1 plays out velocity commands in slow motion.

    Here’s all the details I can think of and the troubleshooting steps I have taken already:

    I’ve tried this with both the stock Ubuntu linux-lowlatency kernel and a custom-built realtime kernel in full preemptive mode with exactly the same results. Further reducing latency by disabling processor C-states, etc, also has had no effect.

    I’m running the new 2.0.0 release of SOMANET-OS and the latest version of the IgH EtherCAT driver (generic) All of the symptoms I have observed are visible in the unmodified SOMANET example software (except for my motor configurations)

    I have two DC100-C22-EtherCAT stacks daisy-chained together to my linux PC. Wiring is Eth0 -> slave 0 COM Port 1 -> slave 0 COM Port 2 – > slave 1 COM Port 1

    If I switch which stack is slave 0 and which is slave 1, slave 1 is still slow.

    Any guidance would be greatly appreciated.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.