Integrated Motion
0
Items : 0
Subtotal : 0,00 
View CartCheck Out

Ethercat Motor Control

Home Forums SOMANET Software Communication layer software Ethercat Motor Control

This topic contains 6 replies, has 0 voices, and was last updated by  seethu.christopher 3 years, 6 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1506

    seethu.christopher

    Hello all,

    I am trying to run the app_demo_slave_ethercat_motorcontrol with app_demo_master_cyclic_position. When I compile the slave side, I get the following error:

    Constraint check for “tile[3]” (node “3”, tile 0):

    Cores available: 8, used: 7 . OKAY

    Timers available: 10, used: 8 . OKAY

    Chanends available: 32, used: 34 . FAILED

    I am using QEI_SENSOR (If I use BISS_SENSOR, the code compiles).

    So I commented out the gpio_service and the code compiles now. But the problem is when I run the master side, the output shows till only ‘Activating Master and Started’. I did a backtrace and found the code goes into init_nodes()->write_sdo() and then its stops.

    I also tried the same with watchdog_service commented out but the same thing happened.

    Can somebody tell me what is happening? How do I get the ethercat example to work? Am I doing something wrong?

    I edited the motor parameters in bldc_motor_config_1.h. I am using a single motor. Should I have changed the parameters somewhere else as well?

    #1512

    seethu.christopher

    Just bumping this up.

    Could someone please help?

    #1534

    peterpoon

    Did you had a solution to this problem ? Changing the code in the slave allowed me to compile, but I still have the problem when starting the master cyclic application with the encoder selected as output. It hangs after updating the motor/control configuration.

    #1536

    Slava

    Please look at this thread. Let me know if the suggestions there were helpful or you still have a problem.

    #1540

    seethu.christopher

    I checked out the develop branch and did ethercat sii_write -p 0 Somanet_ECAT-v3r0.sii. But I am getting the following error:

    Failed to write SII: Input/output error

    When I do dmesg, I can see the following errors:

    EtherCAT ERROR 0-0: SII: Error on last SII command!

    EtherCAT ERROR 0-0: Failed to write SII data.

    Am I doing something wrong?

    Thanks!

    #1541

    Slava

    Hi,

    please make sure that the downloaded sii file is not corrupted.

    Is the node you are updating has a zero position in your EtherCAT topology?

    Unless there is a hardware or contact issue, flashing the sii file should go smoothly. Please also check without the debug adapter between the core module and the EtherCAT board.

    Regards

    #1542

    seethu.christopher

    It worked when I did –position.

    But the example code is still not working. When running the example:

    When I check dmesg, I can see ‘EtherCAT ERROR 0-0: Timeout after 1001 ms while waiting for SDO 0x2410:3 upload response.’

    Also another error: ‘Ethercat ERROR 0-0: Reception of CoE upload request for SDO 0x6091:0 failed with timeout after 1001 ms: No response.’

    And when the master prints ‘updating motor parameters for all connected nodes’, the slave receives ET_ECALL, Application exception and exits the code.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.