Integrated Motion
0
Items : 0
Subtotal : 0,00 
View CartCheck Out

[SOLVED] Cannot build demo project

Home Forums Synapticon/XMOS Motor & Motion Control Kit (EtherCAT) [SOLVED] Cannot build demo project

This topic contains 0 replies, has 0 voices, and was last updated by  stephenrichmond 4 years ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #1486

    stephenrichmond

    I’ve followed the instructions for installing xTimeComposer 13, installed the platform definition files and imported SOMANTEC OS. However, if I select the app_demo_slave_ethercat_motorcontrol project and build it I get an error:

    **** Build of configuration Debug for project app_demo_slave_ethercat_motorcontrol ****

    xmake CONFIG=Debug all
    C:/Program Files (x86)/XMOS/xTIMEcomposer/Community_13.2.3/build/xcommon/module_xcommon/build/../build/Makefile.common1:598: *** Multiple copies of config found: /@@@@C@@@@/Users/Stephen!!!!Richmond/Documents/Bombardier/RobotDrive/Synapticon/SOMANET-OS/sw_sncn_motorcontrol/motor_config /@@@@C@@@@/Users/Stephen!!!!Richmond/Documents/Bombardier/RobotDrive/Synapticon/SOMANET-OS/sw_sncn_motorcontrol_ethercat_kit/config. Stop.
    xmake: *** [bin/Debug/demo-slave-ethercat-motorcontrol_Debug.xe] Error 2

     

    It seems to not like seeing 2 copies of bldc_motor_config.h in 2 separate places.

    Any advice on this much appreciated. Note that I’ve little experience in CC .

     

    Regards

    Steve

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.